Loading...
Remove Text Formatting

Likes Likes:  30
Page 1 of 3 123 LastLast
Results 1 to 10 of 30

Thread: I'm going to drive this thing into a wall

  1. #1
    Member
    Join Date
    Nov 2014
    Location
    Thornhill
    Posts
    49

    I'm going to drive this thing into a wall

    Alright guys,
    I'm getting some greys with this car.

    2002 Mustang gt, long tube headers, catted xpipe, under drive pullies, 1 piece dragon plenum/tb, bbk CAI.

    After the car warms up, and I accelerate passing 3500 rpms... it coughs/looses power, then struggles.
    If i accelerate very slowly, i'm okay... but if i'm merging on the highway and give it throttle... as soon as i go over 50% throttle it coughs and i lose power and the car jerks.
    I've changed the spark plugs, cleaned the MAF and the TB, smoke test for intake cracks - nothing, no issues with coils, oil's good, just did a back pressure test on both cats - perfect, put fresh shell 91 octane. Still does it. I unplugged my fuel pressure sensor last night and drove it, for a minute she was doing good! Then after about 5km she started acting like she had covid.

    What else can I do? Could it be the fuel pump? Anyone been through this nightmare?

  2. #2
    Club Supporter hammerhead's Avatar
    Join Date
    Jun 2018
    Location
    Melancthon,Ontario, Canada
    Posts
    2,605
    any smoke from the exhaust when this happens - maybe check compression if its a high miler or possible egr
    1979 Pace Car 302 4spd
    1981 Cobra t-top option - power to be determined, in the works

  3. #3
    Admin ZR's Avatar
    Join Date
    Mar 2014
    Location
    Toronto, On
    Posts
    58,063
    Is the car tuned?
    Fuel filter done?
    Fuel PSI checked?

  4. #4
    Member
    Join Date
    Nov 2014
    Location
    Thornhill
    Posts
    49
    Quote Originally Posted by ZR View Post
    Is the car tuned?
    Fuel filter done?
    Fuel PSI checked?
    Fuel filter done,
    did a smoke test today and the EGR as well as the throttle shaft is pissing out smoke...more so the EGR.

  5. #5
    Club Supporter Laffs's Avatar
    Join Date
    Mar 2014
    Location
    Windsor, ON
    Posts
    5,058
    Any codes? 2nd ZR's recommendation to put fuel pressure gauge on it and then drive and monitor. Sounds like its starving for fuel under load so could be fuel pump, FPDM, FRPS or even PPRV issues.

    Are you saying its leaking from area around the EGR and TB as in a gasket leak, or just the fact that smoke is escaping from the ports as both open with car off?
    Quote Originally Posted by ludacris View Post
    I'm Supercharged with the HideAway License Plate

  6. #6
    Member
    Join Date
    Nov 2014
    Location
    Thornhill
    Posts
    49
    She's runnin real lean on idle.
    The actual EGR valve is flowing out smoke.

    Plugged in to the fuel rail - 40psi on idle..havent taken it for a spin yet.

    Ordered a new EGR, now on the look out for a new 75mm TB - hopefully it fits the Dragon plenum.

    I think the car does have a tune on it, the older owner didnt know fk all about the car but said it was tuned for 91.

    I'm thinking the EGR and TB will fix the issue abit .. if not - it has to be fuel pump.

  7. #7
    Member
    Join Date
    Nov 2014
    Location
    Thornhill
    Posts
    49
    Quote Originally Posted by Laffs View Post
    Any codes? 2nd ZR's recommendation to put fuel pressure gauge on it and then drive and monitor. Sounds like its starving for fuel under load so could be fuel pump, FPDM, FRPS or even PPRV issues.

    Are you saying its leaking from area around the EGR and TB as in a gasket leak, or just the fact that smoke is escaping from the ports as both open with car off?
    Absolutely no codes.

  8. #8
    Club Supporter Uncle Buck's Avatar
    Join Date
    Mar 2014
    Location
    Willow Beach
    Posts
    2,822
    Seems fuel related to me

  9. #9
    Member
    Join Date
    Nov 2014
    Location
    Thornhill
    Posts
    49
    Yea, as i'm crossing the different variables off i'm thinking its either fuel related - the pump, or the tune.
    Whats weird is, i can shift at 4000+ when the motor is on the colder side... but then give it 10min and boom... it starts to struggle and chokes out.

    It could maybe be the tune as well, i bought a sct bdx - tuner which can unlock, i'm gonna figure out how to return it back to stock. I have a feeling it could be the tune. The guy who owned it before me knew fk all about the car and just drove it slowly on sundays.

  10. #10
    Die Winter Die Snaketamer's Avatar
    Join Date
    Mar 2014
    Location
    North Bay
    Posts
    569
    Quote Originally Posted by Zee View Post
    Whats weird is, i can shift at 4000+ when the motor is on the colder side... but then give it 10min and boom... it starts to struggle and chokes out.
    This makes me think the fuel pump is on it's way out.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

SiteUptime Web Site Monitoring Service